swift and minimum FlightGear version

Some people came in our support channels and asked how they can connect to FlightGear. The documentation gave the impression that everything would be ready with any version of FlightGear. Unfortunately this isn't the case.

FlightGear does not have a plugin system and the available external API was not enough for our needs. Thats why a specific module has been added to FlightGear allowing swift to communicate with it. Unfortunately this means that this cannot be added to released FlightGear versions. Currently the patch is scheduled for version 2019.2, but it might show up in the nightly builds earlier.

Read more about it in http://wiki.flightgear.org/Swift and we keep you posted ones the nightly installers include it.

EDIT 05-24-2019: swift support is now enabled within the next upcoming nightlies for all OSes (Win/Mac/Linux).

Written by rrossgotterer on Apr 15 2019, 8:10 PM.
User
Projects
None
Subscribers
None

Event Timeline