Alpha closed for now
Beta coming soon

Thanks to everyone who has been testing the alpha version of swift. We have enough alpha testers for now, unless you belong to any of the following groups:

  • You want to test the distributed swift version (swift GUI and simulator running on different devices)
  • If you want to test on Linux or Mac
  • If you dare to test the FS9 version, marked as experimental
  • Potential serious C++ developers or GUI designers

All others please wait until we publish our first public beta, which you will be able to download without registration.

Written by kbasan on Jan 24 2019, 2:25 PM.
swift developer
Projects
Subscribers
lezra, owine, mpoole and 2 others

Event Timeline

Count me in as a Linux (Gentoo) user happy to contribute some time to alpha testing. Took a look at the https://datastore.swift-project.org/page/ , but I'm not seeing a method to register. Still need Linux alpha testers?

No need to register. Just login with VATSIM SSO. That creates an account which needs to be approved. I did that for you, so you should be good to go.

mpoole added a comment.EditedFeb 13 2019, 11:36 AM

Where do I use the vatsim sso as I am unable to locate this ?

Upon locating this it doesn’t let me sign in as I have no roles assigned ? I would like to test this along side with Zibo and smartcopilot for xplane 11 me and my friend are running Smartcopilot flawlessly with no issues just need some good ATC program for us both to use

Thanks, Roland!

Michael, the link is on the upper left corner of the link above. Underneath the ID & password fields, there's a "VATSIM members" section, and a link for "Single Sign On". Try that.

As for the Linux software... I seem to have stumbled my way through the documentation well enough to install and configure the standalone client. The xswiftbus plugin doesn't appear to have a fat plugin for Linux, though... Windows and Mac, yes, but no Linux. There's not one residing in the plugin's main directory, at least. There is a lin.xpl in the 64 directory, but X-Plane doesn't seem to be picking it up. Doesn't appear in the plugin menu in the sim, and isn't even mentioned in XP11's Log.txt. Leads me to believe the Linux version of the plugin wasn't compiled & included in the archive.

Or am I missing something? Feel free to direct me to some other "support" channel, by the way... tried entering the chat, but I don't have appropriate rights to the room. I'm not seeing any other forum(s), so I'm grasping onto this blog post like a drowning man hangs onto a buoy. ;D

I've sent you a slack invitation. The support channels are currently under change, hence, it is not promoted much, but for the time being its easier if we continue there. Please join #vatsimtest.

owine added a comment.Mar 11 2019, 5:30 PM

Hi I just registered as I am a Mac user and can help with Mac testing.

lezra added a comment.Mar 17 2019, 7:01 PM

hi just registered, i can help about the mac testing, i am runing my xplane on windows and wish to run swift on macbook